Jump to content

What the ......?

Recommended Posts

Greetings folks!

I have been away for a few days. Just arrived back & anxious to get back into the game. My shortcut does nothing whe I press it. When I try to get in by pressing the 21012 version button on the steam menu it goes through all the correct loading pages until it should give the optioon of which game to load, then the thing just goes off & I am back on my screensaver.

Have tried about 8 times, same result.

Anyone had this?

Any advice would be appreciated, the sooner, the better.


Link to post
Share on other sites

I have been trying since I posted thread. Eventually I tried opening the game through the "Start", "Steam" menu. It has just done an update to the "Steam Platform" then went on to load the game.

So it seems I'm sorted thanks!

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...